Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 21, 2022 - 16:00 UTC
Scheduled
We will be undergoing scheduled maintenance break during this time. This time there will be larger patches regarding the back-end components and the down-time will last for the whole weekend.
AssetNG and Integrations are not available during that time.
Posted Jan 05, 2022 - 12:46 UTC
This scheduled maintenance affected: Asset Management Platform - Asset NG (Acceptance of Deliveries Service, Asset Register, 3FindIT Service, 3CheckIT Service, 3ChooseIT Service, End of Lease Services, 3ConnectIT API Service, Assetwebservice API).