Asset performance issues
Incident Report for 3 Step IT Group Oy Public
Resolved
The results of 2019-11-14 update look good so far, we keep monitoring the outcome.
Posted Nov 15, 2019 - 11:00 UTC
Update
We keep working on the performance issues with some of our customers. 2019-10-20 update provided help, but there are still some pages behaving with degraded performance.
Posted Oct 28, 2019 - 07:36 UTC
Update
We have scheduled a maintenance break to resolve the remaining AssetNG Device Register related performance problems on Oct 18 - Oct 20.
Posted Oct 04, 2019 - 13:13 UTC
Monitoring
Fixes for EOL pages and dashboards have been deployed. We keep monitoring the outcome.
Posted Sep 17, 2019 - 19:19 UTC
Update
Currently main perfomance is still degraded in larger environment when accessing Acceptance of deliveries and End of lease services.

We have adjusted system setting to ensure better background performace, this has partly helpded to restore system performance. We still need to implement hotfix to asset management to get performance in normal level, estimated time to deploy hotfix is 2019-09-18 evening and between 2019-09-20 and 2019-09-22.

We kindly ask all users to wait patiently for the pages to load completely. Trying to reload immediately the temporary slow pages do not help with this particular problem at the moment. We apologize for this inconvenience.
Posted Sep 17, 2019 - 09:00 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 04, 2019 - 07:04 UTC
Investigating
We have identified performance issues in Asset registry background processes. Corrective actions have started, and we keep monitoring system performance continuously.
We apologise for the situation and try to restore normal performance as soon as possible
Posted Sep 04, 2019 - 07:03 UTC
This incident affected: 3StepIT AssetNG Service.