Service outage in 3FindIT and 3CheckIT (Profiler server and Profiler client) services
Incident Report for 3 Step IT Group Oy Public
Resolved
Service outage between 11.02.2023 10:00 - 13.02.2023 10:00 (UTC +2)
Posted Feb 13, 2023 - 08:04 UTC
Investigating
We are currently investigating this issue.
Posted Feb 13, 2023 - 07:15 UTC